Questions

Error running 'requirements_centos_before_install_epel',

0

After installing rvm, I am trying to install ruby using rvm install ruby on redhat server.

But I am getting the below error.

centos_requirements_error.png

After seeing the error of libyaml-devel not installed.

I tried installing it using sudo yum install libyaml-devel.
But then I am getting error like No Package available.

libyaml-devel-error.png

How to resolve this?



asked 1 year, 5 months ago
Reputation: 1





1 Answer

0

With the help of some community I solved this.

Actually: RHEL7 (and 6) include libyaml-devel in the Optional repository. The optional repository is available to any subscriber, but we have to configure it

Trying the below command we can get the version in my case it is libyaml-0.1.4-11.el7_0.x86_64.

sudo yum install libyaml

Now try installing its devel version. In my case I needed to install libyaml-devel-0.1.4-11.el7_0.x86_64.rpm.

Using below command to install:

curl ftp://195.220.108.108/linux/centos/7/os/x86_64/Packages/libyaml-devel-0.1.4-11.el7_0.x86_64.rpm --output libyaml-devel-0.1.4-11.el7_0.x86_64.rpm

sudo rpm -Uvh libyaml-devel-0.1.4-11.el7_0.x86_64.rpm

Now we can install any version of ruby

rvm install ruby-x.x.x

answered 1 year, 5 months ago
Reputation: 1





Your Answer

Nothing to preview

Post Answer



Asked:  1 year, 5 months ago
Viewed:  403 times
Active:  1 year, 5 months ago