Questions

Error: Rocket requires a nightly or dev version of Rust.

0

I am getting an error saying, failed to run custom build command for rocket v0.3.9
process didn’t exit successfully: /Users/aa048326/Documents/Cerner/rust/wiry-rocket/target/release/build/rocket-2112e82d49da8dac/build-script-build (exit code: 101)
— stderr
Error: Rocket requires a nightly or dev version of Rust.
Installed version is: 1.26.0 Minimum required: 1.27.0-nightly

rocket_build_failed_due_to_nightly_error.png



asked 1 year, 5 months ago
Reputation: 1





1 Answer

0

Issue is occurring beacuse of lower version of nighlty.

Updating nightly and changing the default version of nightly should work.

$ rustup default nightly

Above command will update nightly and change the default.

answered 1 year, 5 months ago
Reputation: 1





Your Answer

Nothing to preview

Post Answer



Asked:  1 year, 5 months ago
Viewed:  512 times
Active:  1 year, 5 months ago